New Features Added

  • Added CX7 import support
  • Support for grouping of workflow runs
    • Addition of "group" column to workflowRunListView
    • Group filter on workflowRunListView
    • Edit dialog to change name and group of a workflowRun
    • Support for workflowRun group on datasetGroup auto-analysis
    • Support for workflowRun group on workflowRun creation
    • WorkflowRun group feature can be disabled by the .env parameter NUXT_PUBLIC_DISABLE_WORKFLOW_RUN_GROUPS
  • Support for changing AWS S3 credentials without api-server restart
  • Added reporting features (status report, disk size)
  • Allow cancellation of jobs (feature disabled by default)
  • Addition of stopWorkerJob queue to BullMQ Arena configuration for job cancellation
  • Ensured native czi analysis works in docker container
  • Arivis 4.2 support
    • ARIVIS42_COMPAT component environment variable used for objectserver and arivis-server adoption
  • Enable move of NPM to %ALLUSERSPROFILE%, allowing npm/pm2 to run independent of user profile (requirement on many managed servers)
  • Addition of deleteFile queue to bullmq-viewer
  • Added copy to clipboard button in the screenshot panel (download and copy button are configurable)

Changes to Existing Source Code

  • Resolved issue with worker scaling via Terraform for AWS
  • Enhanced deletion handling of datasets, object files, and orphaned datasets
  • Adjusted file naming templates to handle long file names and commas in CSV files
  • Improved analysis job usage (correct queue, handle duplicate serverTaskIds)
  • Aligned IMPORT_SUPPORTED_FILETYPES with deletable formats
  • Changed data type to BIGINT for subExecutionDurationMs and processingDurationMs
  • Improved logging for audit trail handling
  • Addressed missing Z pixel metadata in Yokogawa CPf (.mmd) from image container detector
  • Allowed longer mainFileS3Uri entries in the AWS S3 Sync database table
  • Updated imageModule version to 3.4.9 ArivisHub 4.2.0 Copyright © Carl Zeiss, 2002-2024. All rights reserved
  • Improved image container detector
  • Added missing file formats for deletion
  • Moved path correction into container detector
  • Resolved double path encoding error and repaired recursive readDir in File Watcher
  • Prevented caching of invalid file-handles
  • Increased TILESERVER_FILE_HANDLE_CLOSE_TIMEOUT_MS to 2 minutes to prevent premature file handle closure
  • Disabled dispose() logs and added logger.time to waitForFileHandlesToClose
  • Added REDIS_MESSAGE_QUEUE_DATABASE to .env.defaults
  • Disabled deletion worker by default and prevented recurring redis connection error messages
  • Repaired hapi logger error on startup
  • Disabled minimization on Webpack build to fix startup error with awilix on Webpack bundle
  • Updated TileServer build pipeline to allow the option to publish to artifacts
  • Frontend improvements for dataset filtering and displaying performance
  • Added UX improvements for the dataset delete dialog
  • Fixed the wrong number of subimages
  • Removed splitting folder name by backslash
  • Displayed error returned from api-server/listDirectories in the Sync AWS S3 Folder dialog
  • Updated compatibility error check for the page analysis pipelines to version 4.2 and adjusted the error text
  • Repaired pipeline description text overflow on the tooltip
  • Changed time format for the duration in the workflow run list
  • Ensured deletion of workflow runs is possible only for creators or admins
  • Showed default image when a dataset is not available
  • Aligned NUXT_PUBLIC_IMPORT_SUPPORTED_FILETYPES with deletable formats
  • Upgraded @vueuse to the latest version
  • Fixed build error after cookie-es update
  • Supported ArivisServer 4.2 (adopted error handling rules)
  • Improved error handling if pixel type is not supported
  • Updated tools to the newest versions
  • Activated gzip compression as a default option (Changed PROXYSERVER_USE_COMPRESSION variable in the .env.defaults file to true)
  • Improved .env generated file on package creation:
    • Added section for individual changes
    • Repaired value for AUDITTRAILSERVER_CMD